返回首页
当前位置: 主页 > 互联网技术 > 网络安全 >

静态路由 配置图解教程

时间:2016-03-07 12:43来源:电脑教程学习网 www.etwiki.cn 编辑:admin

实验环境

如图所示,使用Dynamips搭建网络环境由路由器R1R5构成,路由器PC模拟PC机,R1R2上配置Loopback地址。

1、在R1R2R3上配置静态路由实现网络互通。

R1192.168.2.0/24192.168.23.0/24的路由只经过R2

R2192.168.1.0/24192.168.13.0/24的路由只经过R1

R3192.168.1.0/24的路由只经过R1

R3192.168.2.0/24的路由只经过R2

R3192.168.12.0/24的路由经过R1R2做负载均衡。

2、在R3R4之间配置浮动路由,实现路由备份。

3R5上配置PAT,使PC可以pingR3

4R1上启用telnet,使PC可以远程登录。要求show run中显示的是加密的telnet密码。

具体配置

接口连接

 

Router1 F0/0 <----> Router3 F0/0

Router1 F1/0 <----> Router2 F1/0

Router2 F0/0 <----> Router3 F1/0

Router3 S2/0 <----> Router4 S1/0

Router3 S2/1 <----> Router4 S1/1

Router4 F0/0 <----> Router5 F0/0

Router6 F0/0 <----> Router5 F1/0

R6模拟PC

R1上的配置

Router>en   进入特权模式

Router#conf t   进入全局模式

Router(config)#ho r1   更改设备名称

r1(config)#no ip do lo   关闭域名解析

r1(config)#lin 0   进入控制台

r1(config-line)#no exec-t   关闭超时

r1(config-line)#logg s   关闭日志同步

r1(config-line)#int f0/0   进入F0/0接口

r1(config-if)#ip add 192.168.13.1 255.255.255.0  配置IP 和掩码

r1(config-if)#no shut   开启接口

r1(config-if)#int f1/0   进入F1/0接口

r1(config-if)#ip add 192.168.12.1 255.255.255.0  配置IP和掩码

r1(config-if)#no shut  开启接口

r1(config-if)#int lo0   进入回环口

r1(config-if)#ip add 192.168.1.1 255.255.255.0   配置IP和掩码

r1(config-if)#exit     退回全局模式

r1(config)#ip route 192.168.2.0 255.255.255.0 192.168.12.2  配置去往2.0的静态路由

r1(config)#ip route 192.168.23.0 255.255.255.0 192.168.12.2  配置去往23.0的静态路由

r1(config)#ip route 0.0.0.0 0.0.0.0 192.168.13.3  配置默认路由

r1(config)#lin vty 0 4 进入虚拟链路

r1(config-line)#password 123  配置登录密码

r1(config-line)#login  允许登录

r1(config-line)#exit  退回全局模式

r1(config) #service password-encryption  强制密码加密

 

R2上的配置

Router>en   进入特权模式

Router#conf t   进入全局模式

Router(config)#ho r2  更改设备名称

r2(config)#no ip do lo  关闭域名解析

r2(config)#lin 0    进入控制台

r2(config-line)#no exec-t   关闭超时

r2(config-line)#logg s   关闭日志同步

r2(config-line)#int f0/0   进入F0/0接口

r2(config-if)#ip add 192.168.23.2 255.255.255.0  配置IP和掩码

r2(config-if)#no shut   开启接口

r2(config-if)#int f1/0   进入F1/0接口

r2(config-if)#ip add 192.168.12.2 255.255.255.0   配置IP和掩码

r2(config-if)#no shut  开启接口

r2(config-if)#int lo0   进入回环口

r2(config-if)#ip add 192.168.2.1 255.255.255.0  配置IP和掩码

r2(config-if)#exit       退回全局模式

r2(config)#ip route 192.168.1.0 255.255.255.0 192.168.12.1   配置去往1.0的静态路由

r2(config)#ip route 192.168.13.0 255.255.255.0 192.168.12.1  配置去往13.0的静态路由

r2(config)#ip route 0.0.0.0 0.0.0.0 192.168.23.3  配置默认路由

r2(config)# 

 

R3上的配置

Router>en   进入特权模式

Router#conf t   进入全局模式

Router(config)#ho r3   更改设备

r3(config)#no ip do lo   关闭域名解析

r3(config)#lin 0    进入控制台

r3(config-line)#no exec-t    关闭超时

r3(config-line)#logg s   关闭日志同步

r3(config-line)#int f0/0  进入F0/0接口

r3(config-if)#ip add 192.168.13.3 255.255.255.0   配置IP和掩码

r3(config-if)#no shut  开启接口

r3(config-if)#int f1/0   进入F1/0接口

r3(config-if)#ip add 192.168.23.3 255.255.255.0   配置IP和掩码

r3(config-if)#no shut   开启接口

r3(config-if)#int s2/0   进入S2/0接口

r3(config-if)#ip add 192.168.34.3 255.255.255.0  配置IP和掩码

r3(config-if)#no shut  开启接口

r3(config-if)#int s2/1  进入S2/1接口

r3(config-if)#ip add 192.168.43.3 255.255.255.0   配置IP 和掩码

r3(config-if)#no shut  开启接口

r3(config-if)#exit  退回全局模式

r3(config)#ip route 192.168.12.0 255.255.255.0 192.168.13.1  配置去往12.0的静态路由

r3(config)#ip route 192.168.12.0 255.255.255.0 192.168.23.2  配置去往12.0的静态路由实现负载均衡

r3(config)#ip route 192.168.1.0 255.255.255.0 192.168.13.1  配置去往1.0的静态路由

r3(config)#ip route 192.168.2.0 255.255.255.0 192.168.23.2   配置去往2.0的静态路由

r3(config)#ip route 192.168.45.0 255.255.255.0 192.168.34.4   配置去往45.0的静态路由

r3(config)#ip route 192.168.45.0 255.255.255.0 192.168.43.4 10  配置去往45.0的浮动路由

r3(config)#

 

R4上的配置

Router>en   进入特权模式

Router#conf t   进入全局模式

Router(config)#ho r4  更改设备名称

r4(config)#no ip do lo  关闭域名解析

r4(config)#lin 0   进入控制台

r4(config-line)#no exec-t  关闭超时

r4(config-line)#logg s   关闭日志同步

r4(config-line)#int s1/0  进入S1/0接口

r4(config-if)#ip add 192.168.34.4 255.255.255.0   配置IP和掩码

r4(config-if)#no shut  开启接口

r4(config-if)#int s1/1   进入S1/1接口

r4(config-if)#ip add 192.168.43.4 255.255.255.0   配置IP和掩码

r4(config-if)#no shut  开启接口

r4(config-if)#int f0/0   进入F0/0接口

r4(config-if)#ip add 192.168.45.4 255.255.255.0   配置IP和掩码

r4(config-if)#no shut  开启接口

r4(config-if)#exi  退回全局模式t

r4(config)#ip route 192.168.13.0 255.255.255.0 192.168.34.3   配置去往13.0的静态路由

r4(config)#ip route 192.168.12.0 255.255.255.0 192.168.34.3   配置去往12.0的静态路由

r4(config)#ip route 192.168.23.0 255.255.255.0 192.168.34.3  配置去往23.0的静态路由

r4(config)#ip route 192.168.1.0 255.255.255.0 192.168.34.3   配置去往1.0的静态路由

r4(config)#ip route 192.168.2.0 255.255.255.0 192.168.34.3  配置去往2.0的静态路由

r4(config)#ip route 0.0.0.0 0.0.0.0 192.168.43.3            配置默认路由

r4(config)#

 

R5上的配置

Router>en   进往特权模式

Router#conf t  进往全局模式

Router(config)#ho r5  更改设备名称

r5(config)#lin 0  进入控制台

r5(config)#no ip do lo    关闭域名解析

r5(config-line)#no exec-t   关闭超时

r5(config-line)#logg s   关闭日志同步

r5(config-line)#int f0/0  进入F0/0接口

r5(config-if)#ip add 192.168.45.5 255.255.255.0  配置IP和掩码

r5(config-if)#no shut  开启接口

r5(config-if)#int f1/0  进入F1/0接口

r5(config-if)#ip add 10.1.1.254 255.255.255.0   配置IP和掩码

r5(config-if)#no shut  开启接口

r5(config-if)#exit  退回全局模式

r5(config)#ip route 0.0.0.0 0.0.0.0 192.168.45.4  配置默认路由

r5(config)#access-list 1 per 10.1.1.0 0.0.0.255      配置访问控制列表

r5(config)#ip nat inside source list 1 interface f0/0 overload  配置PAT

r5(config)#int f1/0  进入F1/0

r5(config-if)#ip nat inside   配置NAT进接口

r5(config-if)#int f0/0  进入F0/0

r5(config-if)#ip nat outside  配置NAT出接口

r5(config-if)#end  返回特权模式

 

PC上的配置

Router>en  进入特权模式

Router#conf t  进入全局模式

Router(config)#ho pc  更改设备名称

pc(config)#no ip do lo  关闭域名解析

pc(config)#lin 0  进入控制台

pc(config-line)#no exec-t   关闭超时

pc(config-line)#logg s   关闭日志同步

pc(config-line)#int f0/0   进入F0/0接口

pc(config-if)#ip add 10.1.1.1 255.255.255.0  配置IP和掩码

pc(config-if)#no shut   开启接口

pc(config-if)#exit   退回全局模式

pc(config)#no ip routing  关闭路由功能

pc(config)#ip default-gateway 10.1.1.254  配置默认网关

pc(config)#end   返回特权模式

 

 

 

 测试

pc#ping 192.168.34.3          ping   R3

 

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 192.168.34.3, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 60/92/188 ms

pc#telnet 192.168.1.1            telnet R1

Trying 192.168.1.1 ... Open

 

 

User Access Verification

 

Password:

r1>

 

 

r5#debug ip nat   开启DEBUG查看NAT信息

IP NAT debugging is on

r5#

*Mar  1 00:33:42.035: NAT*: s=10.1.1.1->192.168.45.5, d=192.168.34.3 [10]

*Mar  1 00:33:42.123: NAT*: s=192.168.34.3, d=192.168.45.5->10.1.1.1 [10]

*Mar  1 00:33:42.159: NAT*: s=10.1.1.1->192.168.45.5, d=192.168.34.3 [11]

*Mar  1 00:33:42.223: NAT*: s=192.168.34.3, d=192.168.45.5->10.1.1.1 [11]

*Mar  1 00:33:42.239: NAT*: s=10.1.1.1->192.168.45.5, d=192.168.34.3 [12]

*Mar  1 00:33:42.275: NAT*: s=192.168.34.3, d=192.168.45.5->10.1.1.1 [12]

*Mar  1 00:33:42.315: NAT*: s=10.1.1.1->192.168.45.5, d=192.168.34.3 [13]

*Mar  1 00:33:42.363: NAT*: s=192.168.34.3, d=192.168.45.5->10.1.1.1 [13]

*Mar  1 00:33:42.395: NAT*: s=10.1.1.1->192.168.45.5, d=192.168.34.3 [14]

r5#

*Mar  1 00:33:42.427: NAT*: s=192.168.34.3, d=192.168.45.5->10.1.1.1 [14]

r5#

*Mar  1 00:33:55.351: NAT*: s=10.1.1.1->192.168.45.5, d=192.168.1.1 [59757]

*Mar  1 00:33:55.475: NAT*: s=192.168.1.1, d=192.168.45.5->10.1.1.1 [60948]

*Mar  1 00:33:55.527: NAT*: s=10.1.1.1->192.168.45.5, d=192.168.1.1 [59758]

*Mar  1 00:33:55.527: NAT*: s=10.1.1.1->192.168.45.5, d=192.168.1.1 [59759]

*Mar  1 00:33:55.551: NAT*: s=10.1.1.1->192.168.45.5, d=192.168.1.1 [59760]

*Mar  1 00:33:55.719: NAT*: s=192.168.1.1, d=192.168.45.5->10.1.1.1 [60949]

*Mar  1 00:33:55.727: NAT*: s=192.168.1.1, d=192.168.45.5->10.1.1.1 [60950]

*Mar  1 00:33:55.739: NAT*: s=192.168.1.1, d=192.168.45.5->10.1.1.1 [60951]

r5#

*Mar  1 00:33:55.751: NAT*: s=192.168.1.1, d=192.168.45.5->10.1.1.1 [60952]

*Mar  1 00:33:55.775: NAT*: s=10.1.1.1->192.168.45.5, d=192.168.1.1 [59761]

*Mar  1 00:33:55.775: NAT*: s=10.1.1.1->192.168.45.5, d=192.168.1.1 [59762]

*Mar  1 00:33:55.775: NAT*: s=10.1.1.1->192.168.45.5, d=192.168.1.1 [59763]

*Mar  1 00:33:55.835: NAT*: s=192.168.1.1, d=192.168.45.5->10.1.1.1 [60953]

*Mar  1 00:33:56.035: NAT*: s=10.1.1.1->192.168.45.5, d=192.168.1.1 [59764]

r5#

*Mar  1 00:33:57.079: NAT*: s=10.1.1.1->192.168.45.5, d=192.168.1.1 [59765]

*Mar  1 00:33:57.199: NAT*: s=10.1.1.1->192.168.45.5, d=192.168.1.1 [59766]

*Mar  1 00:33:57.303: NAT*: s=10.1.1.1->192.168.45.5, d=192.168.1.1 [59767]

*Mar  1 00:33:57.395: NAT*: s=192.168.1.1, d=192.168.45.5->10.1.1.1 [60954]

*Mar  1 00:33:57.787: NAT*: s=10.1.1.1->192.168.45.5, d=192.168.1.1 [59768]

*Mar  1 00:33:57.835: NAT*: s=192.168.1.1, d=192.168.45.5->10.1.1.1 [60955]

r5#

*Mar  1 00:33:58.083: NAT*: s=10.1.1.1->192.168.45.5, d=192.168.1.1 [59769]

 

 

r1(config)#do show run  查看R1当前状态

Building configuration...

 

Current configuration : 866 bytes

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

hostname r1

boot-start-marker

boot-end-marker

no aaa new-model

memory-size iomem 5

ip cef

no ip domain lookup!

interface Loopback0

 ip address 192.168.1.1 255.255.255.0     

interface FastEthernet0/0

 ip address 192.168.13.1 255.255.255.0

 duplex auto

 speed auto

interface FastEthernet1/0

 ip address 192.168.12.1 255.255.255.0

 duplex auto

 speed auto

ip http server

no ip http secure-server

ip route 0.0.0.0 0.0.0.0 192.168.13.3

ip route 192.168.2.0 255.255.255.0 192.168.12.2

ip route 192.168.23.0 255.255.255.0 192.168.12.2

control-plane

line con 0

 exec-timeout 0 0

 logging synchronous

line aux 0

line vty 0 4

 password 7 08701E1D  密码已经强制加密

 login

end

 

r1(config)#

------分隔线----------------------------
标签(Tag):静态路由
------分隔线----------------------------
推荐内容
猜你感兴趣